Looking for more information on how to do PHP the right way? Check out PHP: The Right Way

NetBeans Blog:
Code coverage for PHP - why not?
Feb 25, 2009 @ 08:47:44

According to this new post on the NetBeans blog, a new feature - code coverage support - has been added to the most recent version of the IDE.

After a few days, we would like to inform you that code coverage for PHP has been added to the NetBeans IDE. Thanks to PHPUnit (version 3.3 or newer required) we are able to provide code coverage for PHP files in a similar way as for Ruby or Python.

They give the step-by-step (screenshotted) process for running a coverage report on your current project and how to view which tests passed or failed validation.

tagged: codecoverage phpunit unittest netbeans ide sun integrate